Cloud provider partial outage

Incident Report for DigitalEd

Resolved

Our monitoring indicates that Möbius is no longer impacted.
Posted Jun 12, 2025 - 21:09 UTC

Update

Our cloud provider has indicated that the issue is mostly resolved. We continue to monitor.
Posted Jun 12, 2025 - 19:49 UTC

Monitoring

Our cloud provider is currently experiencing an incident. See https://status.cloud.google.com/ for more details.

This could be impacting users in all regions.

We will provide an update as status changes, and will close this incident once we have received confirmation the issue has been resolved from our upstream provider.
Posted Jun 12, 2025 - 19:13 UTC
This incident affected: Americas, Asia Pacific, and Europe, Middle East, Africa, and India.